Sun, 24 Mar 2019 17:15:17 UTC | login

Information for build rh-mongodb36-netty-4.0.42-6.1.bs1.el7

ID24955
Package Namerh-mongodb36-netty
Version4.0.42
Release6.1.bs1.el7
Epoch
SummaryAn asynchronous event-driven network application framework and tools for Java
DescriptionNetty is a NIO client server framework which enables quick and easy development of network applications such as protocol servers and clients. It greatly simplifies and streamlines network programming such as TCP and UDP socket server. 'Quick and easy' doesn't mean that a resulting application will suffer from a maintainability or a performance issue. Netty has been designed carefully with the experiences earned from the implementation of a lot of protocols such as FTP, SMTP, HTTP, and various binary and text-based legacy protocols. As a result, Netty has succeeded to find a way to achieve ease of development, performance, stability, and flexibility without a compromise.
Built byhhorak
State complete
StartedTue, 08 Jan 2019 07:18:26 UTC
CompletedTue, 08 Jan 2019 07:26:14 UTC
Taskbuild (sclo7-rh-mongodb36-rh-el7, rh-mongodb36-netty-4.0.42-6.1.bs1.el7.src.rpm)
Tags
sclo7-rh-mongodb36-rh-candidate
RPMs
src
rh-mongodb36-netty-4.0.42-6.1.bs1.el7.src.rpm (info) (download)
aarch64 (build logs)
rh-mongodb36-netty-4.0.42-6.1.bs1.el7.aarch64.rpm (info) (download)
rh-mongodb36-netty-javadoc-4.0.42-6.1.bs1.el7.aarch64.rpm (info) (download)
ppc64le (build logs)
rh-mongodb36-netty-4.0.42-6.1.bs1.el7.ppc64le.rpm (info) (download)
rh-mongodb36-netty-javadoc-4.0.42-6.1.bs1.el7.ppc64le.rpm (info) (download)
x86_64 (build logs)
rh-mongodb36-netty-4.0.42-6.1.bs1.el7.x86_64.rpm (info) (download)
rh-mongodb36-netty-javadoc-4.0.42-6.1.bs1.el7.x86_64.rpm (info) (download)
Changelog * Mon Aug 07 2017 Marek Skalick√Ĺ <mskalick@redhat.com> - 4.0.42-6.1 - Rebuild for rh-maven35 dependency removal * Fri Jun 23 2017 Michael Simacek <msimacek@redhat.com> - 4.0.42-5.1 - Package import and sclization * Wed Mar 29 2017 Michael Simacek <msimacek@redhat.com> - 4.0.42-5 - Keep Import-Package default value * Thu Mar 16 2017 Michael Simacek <msimacek@redhat.com> - 4.0.42-4 - Remove maven-javadoc-plugin from POM * Wed Mar 15 2017 Michael Simacek <msimacek@redhat.com> - 4.0.42-3 - Add jp_minimal conditional * Mon Feb 06 2017 Michael Simacek <msimacek@redhat.com> - 4.0.42-2 - Remove useless plugins * Thu Oct 20 2016 Severin Gehwolf <sgehwolf@redhat.com> - 4.0.42-1 - Remove old netty4 provides/obsoletes. * Thu Oct 20 2016 Severin Gehwolf <sgehwolf@redhat.com> - 4.0.42-1 - Update to upstream 4.0.42 release. - Resolves RHBZ#1380921 * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.28-3 - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.28-2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild * Wed May 20 2015 Severin Gehwolf <sgehwolf@redhat.com> - 4.0.28-1 - Update to upstream 4.0.28 release. - Fixes CVE-2015-2156 (HttpOnly cookie bypass). - Resolves RHBZ#1111502 * Wed May 20 2015 Severin Gehwolf <sgehwolf@redhat.com> - 4.0.27-1 - Update to upstream 4.0.27 release. * Wed Apr 01 2015 Severin Gehwolf <sgehwolf@redhat.com> - 4.0.19-3 - Drop mvn(org.easymock:easymockclassextension) BR. Resolves: RHBZ#1207991 * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.19-2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild * Mon Jun 09 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 4.0.19-1 - Update to upstream version 4.0.19 - Convert to arch-specific package * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.14-5 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild * Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 4.0.14-4 - Use Requires: java-headless rebuild (#1067528) * Mon Jan 13 2014 Marek Goldmann <mgoldman@redhat.com> - 4.0.14-3 - Enable netty-all.jar artifact * Mon Jan 13 2014 Marek Goldmann <mgoldman@redhat.com> - 4.0.14-2 - Bump the release, so Obsoletes work properly * Mon Dec 30 2013 Marek Goldmann <mgoldman@redhat.com> - 4.0.14-1 - Upstream release 4.0.14.Final * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.6-2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild * Thu May 16 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.6-1 - Update to upstream version 3.6.6 * Wed Apr 10 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.5-1 - Update to upstream version 3.6.5 * Mon Apr 08 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.4-1 - Update to upstream version 3.6.4 * Wed Feb 27 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.3-3 - Set scope of optional compile dependencies to 'provided' * Wed Feb 27 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.3-2 - Drop dependency on OSGi - Resolves: rhbz#916139 * Mon Feb 25 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.3-1 - Update to upstream version 3.6.3 * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.2-3 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild * Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 3.6.2-2 - Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild - Replace maven BuildRequires with maven-local * Wed Jan 16 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.2-1 - Update to upstream version 3.6.2 * Tue Jan 15 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.6.1-1 - Update to upstream version 3.6.1 * Thu Dec 13 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.11-2 - Use system jzlib instead of bundled jzlib - Resolves: rhbz#878391 * Mon Dec 03 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.11-1 - Update to upstream version 3.5.11 * Mon Nov 12 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.10-1 - Update to upstream version 3.5.10 * Thu Oct 25 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.9-1 - Update to upstream version 3.5.9 * Fri Oct 05 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.8-1 - Update to upstream version 3.5.8 * Fri Sep 07 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.7-1 - Update to upstream version 3.5.7 * Mon Sep 03 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.6-1 - Update to upstream version 3.5.6 * Thu Aug 23 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.5-1 - Update to upstream version 3.5.5 * Wed Aug 15 2012 Tomas Rohovsky <trohovsk@redhat.com> - 3.5.4-1 - Update to upstream version 3.5.4 * Tue Jul 24 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.3-1 - Update to upstream version 3.5.3 * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.2-3 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild * Mon Jul 16 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.2-2 - Add additional depmap for org.jboss.netty:netty - Fixes #840301 * Thu Jul 12 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.5.2-1 - Update to upstream version 3.5.2 - Convert patches to POM macros - Enable jboss-logging * Fri May 18 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.4-4 - Add enforcer-plugin to BR * Wed Apr 18 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.4-3 - Remove eclipse plugin from BuildRequires * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.4-2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild * Mon Dec 05 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.4-1 - Update to latest upstream version * Mon Jul 04 2011 Alexander Kurtakov <akurtako@redhat.com> 3.2.3-4 - Fix FTBFS. - Adapt to current guidelines. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.3-3 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild * Mon Jan 17 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.3-2 - Use maven 3 to build - Drop ant-contrib depmap (no longer needed) * Thu Jan 13 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.3-1 - Initial version of the package